Keyword

Topic-icon WCS has stopped working

  • venipenny
  • venipenny's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 5 months ago #8184 by venipenny
WCS has stopped working was created by venipenny
As soon as i click on run on the little options/launch screen, windows tells me that the program has stopped working. It then proceeds to look for a solution, which it doesn't find, and then tells me a problem has stopped the program from working, and that it will close it and notify me if a solution is found. I don't know what the problem is, openAL is installed, i was wondering where should the darkest dawn setup folder go since it contains the cds and such, or does this not matter? why won't it run? i am using Windows 7.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8186 by Luke
Replied by Luke on topic WCS has stopped working
Welcome on board venipenny :)

At the moment it's not easy to help because of this very sparse infos. So i can only say the following:

One try is to check if all files in WCS folder are in a correct state. This can be done with MD5Summer and one of my MD5 checksum files. In german forum i have a thread (point 3) for this MD5 thing, but it's hard for me to translate this all to english. ;)

So another try is to completeley uninstall WCS and doing a fresh install. Your pilot profile (stats, meds, campaign progress, settings, etc.) is safe during this procedure. But if you wish you can backup your complete WCS profile by copying this folder to another place before starting the uninstall process:

My Documents \ Volition \ Wing Commander Saga \

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8187 by Tolwyn
Replied by Tolwyn on topic WCS has stopped working
Thank you for your feedback. Please post your full system specs.

Please Log in or Create an account to join the conversation.

  • venipenny
  • venipenny's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 5 months ago #8227 by venipenny
Replied by venipenny on topic WCS has stopped working
Sorry i've been away. I reinstalled, and it worked, but that was on my laptop which i do not want to play on, so now that i have a new computer, on this one it says "unable to get proper pixel format for open GL Win32!" and gives me this on my clipboard:

Unable to initialize display device!

kernel32.dll! WaitForSingleObjectEx + 26 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes
wcsaga_sse2.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8228 by X3N0-Life-Form
Replied by X3N0-Life-Form on topic WCS has stopped working
First of all, make sure your graphics drivers are up to date.

If that doesn't work, grab Wing Commander Saga's debug build by following the second link in my signature, put it in your Wing Commander Saga folder and run the game using that instead of the launcher.
Once your game crashes, find the file called fs2_open.log in Wing Commander Saga/data, and post it here (either as a post attachment or post what is in it between
).

Please Log in or Create an account to join the conversation.

  • venipenny
  • venipenny's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 5 months ago #8230 by venipenny
Replied by venipenny on topic WCS has stopped working
i did as you said, though when i try opening the debug, i also get the pixel format error. As for the drivers, i suppose they are up to date because it will not let me click update drivers.

==========================================================================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
==========================================================================
FreeSpace version: 1.1.0.7822
Passed cmdline options:
  -fov 0.78540
Building file index...
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_cbanims.vp' with a checksum of 0x2409b26f
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_core.vp' with a checksum of 0xd7728a23
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_effects.vp' with a checksum of 0x0286a101
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_interface.vp' with a checksum of 0x65ead96b
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_maps.vp' with a checksum of 0x8ffa2f7d
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_models.vp' with a checksum of 0x79660cff
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_movies.vp' with a checksum of 0x68a4c02e
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_movies_prologue.vp' with a checksum of 0x9b94783c
Found root pack 'C:\Program Files\Wing Commander Saga\hermes_sounds.vp' with a checksum of 0xe2923047
Searching root 'C:\Users\VeniPenny\Documents\Volition\Wing Commander Saga\' ... 2 files
Searching root 'C:\Program Files\Wing Commander Saga\' ... 0 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_cbanims.vp' ... 11105 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_core.vp' ... 114 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_effects.vp' ... 2052 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_interface.vp' ... 3331 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_maps.vp' ... 2001 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_models.vp' ... 169 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_movies.vp' ... 60 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_movies_prologue.vp' ... 7 files
Searching root pack 'C:\Program Files\Wing Commander Saga\hermes_sounds.vp' ... 5984 files
Found 11 roots and 24825 files.
AutoLang: Language auto-detection successful...
Setting language to English
Sound is disabled!
Failed to init speech
Initializing OpenGL graphics device at 1024x768 with 32-bit color...
  Initializing WGL...
ERROR: Unable to initialize display device!

File: gropengl.cpp
Line: 2014

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8231 by Tolwyn
Replied by Tolwyn on topic WCS has stopped working
It has to be a GPU driver issue - we need full system spec to verify that though.

Please Log in or Create an account to join the conversation.

  • venipenny
  • venipenny's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 5 months ago #8232 by venipenny
Replied by venipenny on topic WCS has stopped working
processor: Intel Core 2 Duo CPU 3.00 GHz

RAM: 4.00 GB

Windows 7 Enterprise 32-bit OS

FPD1975W TFT LCD monitor 1440x900 resolution


display adapter: intel Q45/Q43 exptress chipset


what else do i include?

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 8 years 7 months ago #8234 by Luke
Replied by Luke on topic WCS has stopped working
You must wait for Tolwyn, but until he answer:

I see 2 problems: Sound and Graphic.
  1. Have you installed OpenAL? You can find the installer for that in WCS program folder, called oalinst.exe.
  2. You need a graphic display driver with minimum OpenGL 2.0.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more
Last edit: 8 years 7 months ago by Luke.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8236 by Tolwyn
Replied by Tolwyn on topic WCS has stopped working
OpenAL has nothing to do with the issue - it is a framework used for sound output. Obviously the issue is caused by outdated gpu drivers, most likely obtained through Windows Update.

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 11.413 seconds